New Exploit Can Downgrade iOS 5.1 To iOS 5.0.1 On iPad 2 And iPhone 4S

Ads

World renowned iOS hacker iH8sn0w has discovered a new exploit. This exploit can be used to downgrade iOS 5.1 to iOS 5.0.1 on iPad 2 and iPhone 4S. These A5 based devices can not be downgraded using the methods that work with older generation iOS devices. The new exploit is a much needed discovery.

Downgrade iOS 5.1 To iOS 5.0.1

The iPad 2 and iPhone 4S are A5 based devices. These devices have proved to be very hard to jailbreak or develop an exploit for. Apple has tightened the security and finding exploits for A5 devices is proving to be a daunting task. A bootrom exploit makes things much simpler, but to date only too userland exploits have been found and developed for use with A5. Userland exploits aren't that useful in the long run, considering the fact that Apple can easily patch them in the next firmware update.

Jailbreakers and iOS enthusiasts alike were very excited when iH8sn0w revealed through Twitter that he has discovered a new exploit. This exploit will play an important part, particularly for those who own iPad 2 and iPhone 4S. He is yet to reveal any finer details about this exploit. It isn't even known right now when he plans on making this exploit available to the public in usable form. He did however mention that the exploit will work with A5X based New iPad as well once Apple releases a new firmware for it.

Why is this discovery so important? It is essential for those who want to downgrade iOS 5.1 to iOS 5.0.1 on their iPad 2 and iPhone 4S. These devices can not be downgraded using any other method. A downgrade is important because there is no jailbreak available for iOS 5.1, not even a tethered one. iOS 5.0.1 has been jailbroken on A5 devices, so being able to downgrade iPhone 4S and iPad 2 to iOS 5.0.1 opens up the possibility of jailbreaking said device.

I am sure many who mistakenly upgraded their iPad 2 or iPhone 4S anxiously wait for a way to downgrade iOS 5.1 to iOS 5.0.1. It's only a matter of time before the release takes place. However do remember that your iOS 5.0.1 saved SHSH blobs will be vital to the whole procedure. If you didn't save iOS 5.0.1 SHSH blobs when they could have been saved, there's probably nothing you can do to downgrade iOS 5.1 to iOS 5.0.1.